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License Agreement
Your use of this software indicates your acceptance of 
this license agreement and warranty. Please carefully 
read these terms and conditions prior to the use of 
this software.

Copyright
All title and copyrights in and to this software are 
owned by KORG Italy SpA (hereafter simply indicated 
as "Korg"). This software is protected by copyright 
laws and international treaty provisions.

Freeware
Although this software is free, it is not "public do-
main". It is a copyrighted software program, and Korg 
reserves all rights. Therefore:
• This software cannot be sold, either by itself or in 
combination with any other product, without the ex-
press written permission of Korg.
• If you are a user group which is publishing a CD-ROM 
or floppy collection, you may include this software and 
all of its related files without restriction, save that the 
entire original package is included.
• If you are a hard disk vendor which distributes PD, 
shareware, and freeware on your disk drives, you are 
welcome to distribute this software. Contact Korg for 
up-to date versions and information.
• Commercial publishers and distributors of CD-ROM 
software collections, to include any and all software 
compilations provided as an adjunct to printed or on-
line publications, may not distribute this software on 
CD- ROM without the express written permission of 
Korg.
• This software may be posted on an information ser-
vice which charges its users for general connection 
time and downloading, but it may NOT be posted to an 
information service which will charge for the specific 
right to download it, without the express written per-
mission of Korg.
• This software may be given away as a support utility 
for a package which is itself to be given away. People 
who need to distribute it as a support utility should 
contact Korg for up-to-date versions and information.
Please address all correspondence to: 
 KORG Italy SpA
 Via Cagiata, 85
 60027 Osimo (AN) - Italy
 www.korg.com
Please note that we cannot provide technical support 
for this software (or any of our other freeware prod-
ucts).

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES 
ARE DISTRIBUTED "AS IS" AND WITHOUT WARRAN-
TIES AS TO PERFORMANCE OR MERCHANTABILITY 
OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED. NO WARRANTY OF FITNESS FOR A PAR-
TICULAR PURPOSE IS OFFERED.

Distribution
This software is freeware and may be freely copied 
and distributed as long as the entire unmodified pro-
gram is copied and no fee is charged.

Support
This software is given "as is". No support is granted 
by Korg.

Liability
Korg shall not be liable for errors contained in infor-
mation and software downloaded from the Korg Web-
site, or otherwise obtained from the Korg Website in 
any manner. Korg will not in any event be liable for any 
direct, indirect, special, incidental or consequential 
damages whatsoever (including lost profits, lost data, 
or business interruption) related to any use, repro-
duction, modification, or distribution of the software, 
results, documentation or links provided by the Korg 
Website.

No Disassembly or Decryption
You may not disassemble or decompile the Software 
without prior written consent of Korg.

Transfer
Your license will automatically terminate upon any 
transfer of the Software. Upon transfer, you must de-
liver the Software, including any copies and related 
documentation, to the transferee. The transferee 
must accept these License Terms as a condition to the 
transfer.

Termination
Korg may terminate your license upon notice for 
failure to comply with any of these License Terms. 
Upon termination, you must immediately destroy the 
Software, together with all copies, adaptations and 
merged portions in any form.

Data Handling
Data may sometimes be lost due to incorrect user ac-
tion. Be sure to backup important data. Korg will not 
be responsible for damages caused by data loss.

Disclaimer
The information contained in this manual have been 
carefully revised and checked through. Due to our 
constant efforts to improve our products, the speci-
fications might differ to those in the manual. Korg is 
not responsible for any eventual differences found 
between the specifications and the contents of the in-
struction manual – the specifications being subject to 
change without prior notice.

Trademarks
Windows is a registered trademark of Microsoft Corpo-
ration. All other trademarks or registered trademarks 
are the property of their respective holders.

http://www.korg.com


1

English

Contents
Introduction  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .3

Installing the software  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

PC system requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Korg Pa requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .4

Installing the software . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5

Getting help . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5

SongBook and removable media  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .5

Creating and editing the SongBook database on the Pa   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .6

Creating the Style-based SongBook entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Creating the Standard MIDI File- and MP3 file-based entries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Saving the SongBook files to the internal memory . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6

Exporting custom Factory Style names . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .7

From here on – do not edit anything on the Pa! . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .7

Connecting the devices and running SongBook Editor  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 8

Connecting the Pa to a PC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

Launching SongBook Editor  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

Choosing the Target . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

Opening the SongBook file with SongBook Editor  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 11

Opening the SongBook file  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11

Browsing the SongBook entries in the Book panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .11

Customizing the list view . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Showing/hiding columns . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Resizing columns  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

Changing the sorting order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Changing the fonts and colors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Filtering the entries shown in the Book panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Creating a new SongBook file with SongBook Editor  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 16

Creating new SongBook entries  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 17

Creating a new SongBook entry . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Linking resources  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Linking resources from an USB storage device . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Importing data to SongBook entries  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 19

Importing Standard MIDI Files and/or MP3 files. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Preparing the data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Importing the files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20



2

Editing basics  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 21

How to access editing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Editing parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Editing multiple entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

How to edit the parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

Editing text strings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

Choosing parameters from a pop-up menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

Automatically updated pop-up menus  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .22

Cutting, copying and pasting the entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .23

Deleting entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .23

Selecting all entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .23

Editing the SongBook entries  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 24

Editing Style-based entries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .24

Editing Standard MIDI File-based entries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Editing MP3-based entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Custom Lists  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 31

Creating a new Custom List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Adding entries to the selected Custom List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Seeing the content of a Custom List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32

Editing entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32

Moving entries up/down . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .32

Deleting a Custom List . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .33

Frequent operations  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 34

Changing reference to a bank of Styles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Changing reference to individual Styles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .37

Changing the device and path to your Standard MIDI Files, MP3 files and Lyrics text files . . . 40

Merging entries from two SongBook files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

Exporting a list of entries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42

Saving the SongBook files and reloading to the Pa  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 43

Saving the edited SongBook file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Quitting SongBook Editor. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Disconnecting the Pa from the PC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Loading the edited SongBook files on the Pa . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

Appendix  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 45

Keyboard shortcuts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Version History  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46



3

English

Introduction
Thank you for using Korg’s SongBook Editor for the Pa-Series Professional 
Arrangers. All models featuring the SongBook function are supported, including 
Pa3X, Pa900, Pa600, Pa300, Pa2X Pro, Pa800, Pa1X, Pa1X Pro, Pa1X Elite, Pa500 
and Pa588.

With SongBook Editor you can comfortably view and edit a Korg Pa-Series 
SongBook file on your PC. This software allows you to:

• Create new SongBook entries.

• Import multiple Standard MIDI Files and MP3 files.

• Edit most entry parameters in multiple entries at once.

• Rename entries and edit parameters faster, by using the PC’s keyboard.

• Add Lyrics as TXT files linked to the entries.

• See all parameters in adjacent columns, and quickly sort the entries in the Book 
list.

• Create and edit Custom Lists, using multiple selection and drag&drop.

• Drag&drop entries between SongBook files, and between SongBook files and 
text documents or spreadsheets.

• Change reference to Style locations and banks.

• Change the file path of Standard MIDI Files, MP3 files and text files.

• Export a list of songs as a text file, to print your playlist for a show.
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Installing the software

PC system requirements

To use SongBook Editor, you need a PC running under Microsoft® Windows® 
XP/Vista/7/8™.

Note: Windows Installer version 2.0 (or higher) is required, and can be freely downloaded 
from Microsoft’s website.

Korg Pa requirements

The following table shows the requirements to use SongBook Editor with your 
Korg Pa.

OS MP3 HD/SSD SD Card

Pa3X latest version standard standard —

Pa900 latest version standard standard —

Pa600 latest version standard standard —

Pa300 latest version standard standard —

Pa2X latest version standard standard —

Pa800 latest version optional suggested —

Pa1X latest version optional required —

Pa1X Pro latest version optional standard —

Pa1X Elite latest version standard standard —

Pa500/Pa588 latest version — — required

Note: You can find the latest OS in our web site (www.korg.com).

Note: MP3 entries will only work on models with an MP3 board installed, or with MP3 read-
ing capabilities included as a standard feature.

http://www.korg.com
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Installing the software

After downloading the installer, follow these easy steps:

1 Double-click the installer’s icon.

2 Follow the instructions appearing on screen.

Getting help

Whenever you need to access these instructions, choose the Help > SongBook 
Editor User Guide (F1) command from the application menu.

SongBook and removable media

While running, SongBook Editor cannot see any USB memory device connected 
to your Pa’s USB Host ports. However, it can read resources (Standard MIDI Files, 
MP3 files, TXT files) from an USB memory device connected to the PC’s USB 
port. You can therefore work with files on an USB memory device connected to 
your PC’s USB port, and then move it to your Pa.

A microSD card inserted in the slot of a Pa900, or an SD card inserted in the slot 
of your Pa500/Pa588, can be seen by SongBook Editor. While this is a remov-
able media, it is considered the internal memory of the instrument, and can be 
accessed by activating the USB connection via the Media > USB > Enable com-
mand on the Pa.

Due to their low access speed, no floppy disks or CDs inserted in the Pa1X’s 
drives can be seen by SongBook Editor.
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Creating and editing the 
SongBook database on the Pa
Before editing your SongBook files with SongBook Editor, there are some opera-
tions you should carry on on your Pa to create your original SongBook.

Creating the Style-based SongBook entries

It is advisable to create Style-based entries on the Pa, since this way all the 
actual values of the Style Settings or Style Performance (including Sounds, EQ, 
FX, STS, etc…) will be copied to the SongBook entries. On the contrary, creating 
Style-based entries with SongBook Editor would only assign them default values, 
and would therefore require some additional work.

1 On the Pa, create a new SongBook database, or edit an existing one. Please read 
the Pa’s User Manual for the relevant instructions.

2 Still on the Pa, create all Style-based SongBook entries, as described in the User 
Manual.

Creating the Standard MIDI File- and MP3 file-
based entries

If you want, create the Standard MIDI File- and MP3 file-based entries on the Pa. 
However, please keep in mind that you can do it in an easier and quicker way by 
using SongBook Editor.

Saving the SongBook files to the internal memory

Before editing the SongBook database with SongBook Editor, you must create 
the relevant files in the internal memory of your Pa.

1 On the Pa, save the SongBook file to the internal memory, by using the Media 
(Disk) > Save All operation. A new “.SET” folder will be created, containing the 
Book (“.SBD”) and Custom List (“.SBL”) files, together with all the other User 
data.
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2 For safety reasons, we suggest you create a second copy with a different name, 
to be used as a backup copy.

Important: Always keep a backup copy of your original SongBook files before editing 

them! Saving an edited SongBook file over an existing one will delete the older one.

Exporting custom Factory Style names

Standard Factory Style names are always shown in SongBook Editor, depending 
to your Pa-Series model. If you customized the Factory Style banks, you have to 
export their names.

1 On the Pa, remove the write and save protection from the Factory Styles, by 
unchecking the Media Factory Style and Pad Protect parameter in the Global > 
Mode Preferences > Media, or the Media (Disk) > Preferences page.

2 Save the Factory Styles, as explained in the following table.

Model Factory Style procedure

Pa900, Pa600, 
Pa300

Save the Factory Styles together with the other data, by using the Media > 
Save All.

Pa3X, Pa2X, 
Pa800, Pa1X, 
Pa500, Pa588

Separately save each single Factory Style bank into the “.SET” folder where 
you will save the SongBook files, by using the Media (Disk) > Save > Bank op-
eration. Save all Factory Style banks, or the missing banks will not appear in 
SongBook Editor.

From here on – do not edit anything on the Pa!

Starting from the following pages, all editing will be done on a PC and not on 
your Pa. Any further editing carried on on the Pa before reloading the modified 
SongBook files will be lost.
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Connecting the devices and 
running SongBook Editor
Before editing the SongBook files, you must connect your Pa to a PC, and run 
SongBook Editor.

Connecting the Pa to a PC

To make your Pa communicate with a PC running SongBook Editor, you must 
connect them by using an USB cable. When it is connected to a Pa, the PC can 
see the instrument’s internal memory as if it was an ordinary storage device. At 
this point, you can directly work on the SongBook files, the Standard MIDI Files, 
the MP3 files and the TXT files contained in the internal memory of the Pa.

1 Use a standard USB cable to connect the USB Device port of the Pa to an USB 
port of the PC.

2 On the Pa, go to the Media (Disk) > USB page, and press the Enable button. The 
icon of the Pa’s internal memory will appear among those of all the devices con-
nected to your PC.

Launching SongBook Editor

After having connected the Pa to a PC, run SongBook Editor. The main screen of 
the software will appear, with a standard menu and a single window split in three 
panels, as shown in the illustration below. (When first running the application, 
the panels are empty; we show them populated for ease of understanding).
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The “Book” panel. This is where the full list of 
Songs included in a “.SBD” file appears. It is the 

equivalent of the “Book” page of the Pa.

The “Custom List” panel. This is where you can see all the available 
Custom Lists (“.SBL” file) associated to the selected Book (“.SBD” 
file). All available Custom Lists are included in the same file. This 

panel is the equivalent of the “Custom List” pop-up menu of the Pa.

The “Selected List” panel. This is 
were you can see the content of 

the selected Custom List. It is the 
equivalent of the “Custom List” 

page of the Pa.
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Choosing the Target

The first time you run SongBook Editor, use the Target parameter in the 
Preferences dialog box to select your instrument as the “target” device. This will 
allow the software to use the correct file format for your instrument. You won’t 
need to select it again later, since this setting will remain memorized through all 
the following editing sessions.

Please note that SongBook entries created with more recent Pa-Series models 
could be removed from the SongBook file, when choosing an older model as the 
target.

Chosen Target Entries created with Pa3X, Pa900, Pa600, Pa300

Pa3X, Pa900, Pa600, Pa300 Always preserved

Other Pa-Series Models Removed when choosing this target or opening a SongBook file

1 Choose the File > Preferences… command to open the Preferences dialog box. 
You will see the Target parameter on top of the dialog box.

2 Click the Change… button to open the Target dialog box.

 

3 Choose from the list the Target corresponding to your instrument, then click the 
OK button to confirm.

4 Click the OK button to close the Preferences dialog box.

When done, the chosen Target will be shown in the top-right corner of the ap-
plication window.
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Opening the SongBook file 
with SongBook Editor
The SongBook file can be opened with SongBook Editor, where you can see its 
content in a database-like fashion.

Opening the SongBook file
Before editing, open the SongBook file from the internal memory of the Pa.

1 In SongBook Editor, choose the File > Open command, and browse the files in the 
internal memory of the Pa.

2 Find the “.SET” folder containing your Pa’s internal memory data, and click its 
name to highlight it.

3 Click the OK button to choose the “.SET” folder. As a consequence, the SongBook 
(“.SBD”) and Custom List (“.SBL”) files contained in the “.SET” folder will be 
loaded to SongBook Editor.

Browsing the SongBook entries in the Book panel
After opening the SongBook file, the list of SongBook entries that it contains will 
appear in the Book panel (corresponding to the Book page on the Pa). Here you 
can view and edit the content of the SongBook (“.SBD”) file. The Book’s content 
is shown in a database-like fashion, with each SongBook entry corresponding to 
a row, and the various parameters of the entry shown in the adjacent columns.
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Customizing the list view

Showing/hiding columns

You can choose which columns to see in the panels.

1 Click a column header with the right mouse button.

2 When the list of available options appears, check/uncheck the name of the col-
umn to be shown/hidden.

Resizing columns

You can change the width of each column to better fit the content.

1 When moving the mouse pointer over the line dividing two column headers, the 
pointer’s shape changes to the resize tool. Grab the right margin of a column 
header, then drag it.

2 To set a column’s width to the optimum size, double-click its right margin.
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Changing the sorting order

You can change the order of the SongBook entries shown in the list, by choosing 
a particular sorting criterion (by Name, Genre, Author, and so on).

1 Click a column header to select the corresponding sorting criterion.

2 Click a second column header to change the sorting.

Each time you choose a different sorting criterion, the previous criterion is con-
sidered as a “sub-criterion” for the new one. For example, you can alphabetically 
order your entries by Name:

Then you change the order to Genre; inside the genre alphabetical ordering, 
entries are still alphabetically ordered by name:

3 Click the selected column header to change the sorting order from ascending to 
descending, or vice versa.
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Changing the fonts and colors

Fonts and colors of the list items can be customized.

1 Choose the File > Preferences… command to open the Preferences dialog box.

2 Use the options of the Fonts & Color section to change the fonts and assign a 
different background color to the various panels. You can also assign different 
background colors to the alternating odd and even rows. Entries edited but not 
yet saved can have their own color.

3 When done, click the OK button to close the dialog box.
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Filtering the entries shown in the Book panel

If you want to view only the SongBook entries based on the songs of a single 
author, or the songs of a particular genre, or selected according to other criteria, 
you can apply a ‘filter’ to the current view.

1 To define the view criteria click the Filter… button on the lower left corner of the 
Book panel, or choose the Edit > Filter… (Ctrl+F) command to open the Filter 
dialog box.

2 Edit the various filtering criteria (the available criteria are the same as on the 
Pa). When done, click the OK button to close the dialog box.

3 Click the Filtered checkbox in the lower left corner of the Book panel to make 
the checkmark appear. The entries shown in the Book panel will change.

4 When you want to see all the entries again, remove the checkmark from the 
Filtered checkbox.
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Creating a new SongBook file 
with SongBook Editor
You can create a new, empty SongBook file, where you can manually add new 
entries or import Standard MIDI Files and MP3 files to automatically create new 
entries.

• To create a new SongBook file, choose the File > New command from the menu.
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Creating new SongBook 
entries
You can create new entries, to be added to a new or existing SongBook file.

Creating a new SongBook entry

You can create three different types of SongBook entry.

1 Use the Edit > New Entry commands to create new SongBook entries with 
SongBook Editor. 

• Choose the Edit > New Entry > Style (Ctrl+N) command to create a Style-based 
entry. As an alternative, right-click and choose the New Entry > Style command.

• Choose the Edit > New Entry > MIDI (Ctrl+Shift+N) command to create a 
Standard MIDI File-based entry. As an alternative, right-click and choose the 
New Entry > MIDI command.

• Choose the Edit > New Entry > MP3 (Alt+N) command to create an MP3 file-
based entry. As an alternative, right-click and choose the New Entry > MP3 
command.

2 Edit the various parameters in the Edit dialog box (see “Editing the SongBook 
entries” on page 24).
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Linking resources

When you create a new entry, you can link any of the resources contained in your 
Pa’s internal memory. You can also link some of the resources from an USB stor-
age device, as described below.

Resource Type Position

Style System

Standard MIDI File Internal memory, USB storage device

MP3 file Internal memory, USB storage device

TXT file Internal memory, USB storage device

VP Preset System

Please keep in mind that no resource is copied into the SongBook entries, but 
they are only linked to them. If you move the SongBook file to a different instru-
ment, or the resources to a different folder, links can be broken, unless you recre-
ate exactly the same data structure (see “Frequent operations” on page 34).

Linking resources from an USB storage device

You might want to keep your Standard MIDI File, MP3 file and TXT file collections 
on an USB storage device (memory stick, external HD drive…) instead of your 
Pa’s internal memory. This will allow to use extensive MP3 libraries, and keep all 
the resources always with you.

Move all your resources to an external USB storage device. While editing a 
SongBook file with SongBook Editor, connect the USB storage device to the PC. 
When finished editing, connect the USB device back to your Pa. When using the 
SongBook, your Pa will need this device to be connected to its USB Host port.
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Importing data to SongBook 
entries
Instead of being individually created one by one, SongBook entries can be cre-
ated en masse by importing a series of Standard MIDI Files or MP3 files.

Importing Standard MIDI Files and/or MP3 files

You can import all the Standard MIDI Files and MP3 files contained in a folder 
residing inside the internal memory of your Pa, or in an external USB storage 
device. These files will be automatically converted into SongBook entries. The 
imported entries can be added to an existing SongBook file, or to a new, empty 
SongBook file.

In case there are ID3 data inside the imported MP3 files, these will be converted 
into SongBook data (Title, Author…). Basic data and some metadata contained 
inside Standard MIDI Files will also be converted into SongBook data (Key, Time 
Signature, Tempo…). With Pa3X, Pa900, Pa600 and Pa300, the Master Transpose 
is also converted.

Preparing the data

Copy all your Standard MIDI Files, MP3 files and TXT files into the internal mem-
ory of the Pa, or an external USB storage device to be used as your Pa’s external 
library. All the referred files will have to stay in the same place, and be accessible 
from your Pa when you will use the SongBook file you are editing.

1 Connect any external storage device to your PC. If you intend to use an USB stor-
age device as the Pa’s external library, connect it to the PC.

2 Connect your Pa to the PC, and activate USB connection on the Pa.

3 Open the external devices and the Pa memory content into new windows of your 
PC’s desktop.

4 Copy all the sparse “.MID”, “.MP3” and “.TXT” files from the external devices to 
the internal memory of the Pa or the USB storage device to be used as the Pa’s 
external library. Collecting the different types of songs in separate folders (for 
example, by genre or by type of file) will help you retrieve them later.

Important: Do not copy files inside any of the “.SET” folders! These folders are reserved 
to the Pa’s internal data, and must be left untouched. Use generic folders instead.
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Importing the files

After you have moved all the files into your Pa’s internal memory or external 
library device, start importing them.

1 In SongBook Editor, choose the File > Import Files… (Ctrl+I) command. A stan-
dard file selector will appear. You can then select files from the internal memory 
of your Pa or from the external library device.

2 Select the file(s) with the “.MID”, “.KAR” and “.MP3” extensions you want to im-
port. Then click the Open command to import the selected Standard MIDI Files 
and MP3 files, and convert them to SongBook entries.

Hint: When in this file selector, you can use the Shift+click shortcut to select multiple con-
tiguous files, or the Ctrl+click shortcut to select multiple non-contiguous files.
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Editing basics
Before editing, please learn the basic editing operations. These operations affect 
the entries in all panels (Book, Custom Lists, Selected List).

How to access editing

Editing parameters

• Double-click the entry you want to edit to open the Edit dialog box (see “Editing 
the SongBook entries” on page 24).

• As an alternative, right-click it, and choose the Edit command.

Please note that not all parameters can be edited, and not all parameters may appear 
for the chosen target. The following table shows which parameters can or can’t be 
edited. Please see the Pa’s User Manual for more information on their meaning.

Parameter Editable

Index (only in Custom List entries)

Sel.No. (Song Selection Number) √

Type (Resource Type)

Name (SongBook Entry’s Name) √

Artist √

Genre √

Key √

Tempo 

Meter √

Master Transpose 

Synchro Start (Synchro Start button) √

Synchro Stop (Synchro Stop button) √

Memory (Memory button) √

Harmony Track √

Voice Preset / Use Global Voice Preset √

Resource
Style based entry: Style bank and Style name. Song based entry: File path (including name) 
of the associated Standard MIDI File or MP3 file

√

Txt file
File path (including name) of the text file associated to the SongBook entry 

√



22

Entries that have been edited, but not yet saved, are shown in red. They will be-
come black again once the SongBook file has been saved. Please note that text 
colors can be customized in the Preferences dialog box (see “Changing the fonts 
and colors” on page 14).

Editing multiple entries

You can select and edit more that a single entry at once. Please be advised that 
some parameters cannot be modified when editing multiple entries (for example, 
the entry’s name, or parameters pertaining to different types of entries).

1 Click the entries to select.

• Select more consecutive entries by Shift-clicking.

• Select more non-consecutive entries by Control-clicking.

2 Right-click the selected entries and choose the Edit command.

How to edit the parameters

Editing text strings

Some parameters – for example, SongBook entry names – require you enter a 
text string. Note that names are case-sensitive, i.e., “Name” is not the same as 
“name”. Also, please note that duplicate entry names are not allowed.

Choosing parameters from a pop-up menu

Some parameters allow you to choose a value from a pop-up menu. Click the 
down-pointing arrow next to the option name and choose the desired value.

Automatically updated pop-up menus

Each time you create a new entry or edit an existing one, all its data are added 
to the various pop-up menus, so that you can choose them when entering/edit-
ing other entries. For example, if you enter “Rock” in the Genre field, and this 
genre is not yet included in the list, the “Rock” option will be automatically add-
ed to the Genre pop-up menu. Pop-up menus grow each time you enter a new 
SongBook entry.
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Cutting, copying and pasting the entries

You can use the standard Cut, Copy and Paste operations inside SongBook Editor, 
between different SongBook Editor instances, or between SongBook Editor and 
a text editor or spreadsheet. The clipboard’s content is in the “text delimited by 
tabs” format.

• Choose the Edit > Cut (Ctrl+X) command to cut the selected item(s) and move 
it (them) to the clipboard. As an alternative, right-click the item(s) and choose 
the Cut command.

• Choose the Edit > Copy (Ctrl+C) command to copy the selected item(s) to the 
clipboard. As an alternative, right-click the item(s) and choose the Copy com-
mand.

• Choose the Edit > Paste (Ctrl+V) command to paste at the current position the 
item(s) contained in the clipboard. As an alternative, right-click and choose the 
Paste command.

Deleting entries

• Select the item(s) to be deleted, then choose the Edit > Delete (Del) command 
to delete. As an alternative, press the Delete key, or right-click and choose the 
Delete command.

Selecting all entries

• Choose the Edit > Select All (Ctrl+A) command to select all the entries.

• As an alternative, right-click and choose the Select All command.
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Editing the SongBook entries
By opening the Edit dialog box, you can edit the fine details of each new or exist-
ing entry.

Editing Style-based entries

This type of entry will automatically select the Style Play mode and select a 
Style.

• Choose a Style-based entry, and double-click it to open the Edit Style Entry 
dialog box.

With this type of entry, you can choose (respectively) the bank and position num-
ber of the assigned Style.

(2)

(1)

(6)

(7)

(3)

(4) (5)

(1) Parameters (2) Style Bank (3) Style  
(4) TXT file drive unit (5) TXT file path (6) TXT file browse icon  

(7) Previous/Next Entry buttons

Parameters — These are the same parameters found in the Book pages of the 
instrument. The Tempo and Master Transpose values are those saved into the 
Style Settings (Style Performance).
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Style Bank — Each bank may contain the maximum number of Styles shown in 
the table below. Each group of 8 consecutive Styles corresponds to one of the 
tabs shown in the Style Select window of the instrument. Here are the banks that 
can be chosen:

# Type Style per Bank

Pa3X/Pa900/Pa600

1-15 Factory 40

18-20 User 40

21-32 Favorite 40

Pa300

1-15 Factory 40

18-20 User 40

21-28 Favorite 40

Pa2X/Pa800

1-17 Factory 32

18-20 User 32

21-30 Favorite 32

Pa1X/Pa1X Pro

1-16 Factory 32

18-20 User 32

21-23 Direct FD (B:\DIRECTFD.SET) 32

24-26 Direct HD (C:\DIRECTHD\BANK123.SET) 32

27-29 Direct HD (C:\DIRECTHD\BANK456.SET) 32

30-32 Direct HD (C:\DIRECTHD\BANK789.SET) 32

33 EXB01 64

34 EXB02 64

Pa500/Pa588

1-14 Factory 32

15-16 User 32

Style — This is the Style inside the selected Bank; both the Style number and 
name are shown.

Text drive unit and path — The text path is divided into the drive unit (on the left) 
and the actual path (on the right). This allows you to change the drive separately 
from the path, so that you can copy entire directories between drives, without 
having to re-edit long directory strings.
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An example of path is the following:

c:\foldername1\foldername2\filename.txt

When editing multiple entries, you can only edit the path, but not the file name; 
this is useful if you renamed a folder, or have moved the text files to a different 
folder or directory level. Check the Text file path checkbox, and enter a string 
similar to the following one (without any final backslash):

c:\newfoldername1\newfoldername2

Storage devices, like hard drives and USB storage devices, are represented by 
IDs, as indicated in the following table:

ID Storage device

Pa3X

C2: or [label]* Internal memory (Hard Disk/SSD)

[label]* Storage device connected to one of the USB Host ports

Pa900

C2: or [KORG DISK]* Internal memory (SSD)

[KORG SD]* Internal memory (microSD)

[label]* Storage device connected to the USB Host port

Pa600/Pa300

C2: or [KORG DISK]* Internal memory (SSD)

[label]* Storage device connected to the USB Host port

Pa2X/Pa800

F2: or [label]* Internal SSD-U memory

C: or [label]* Internal Hard Disk

[label]* Storage device connected to one of the USB Host ports.

Pa1X/Pa1X Pro

B: Floppy Disk

C: or [label]* Hard Disk

D: CD Drive

Pa500/Pa588

E: or [label]* SD Card

* The [label] is the name assigned to the storage device. When writing the label by hand, do not 
forget to also include the square brackets around the name (e.g., “[KHD_USER]”).
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Browse icon — Click this icon to open a standard file selector, and choose the 
text file.

Previous/Next Entry buttons — Click the Previous button to edit the previous 
entry of the list, or the Next button to edit the next entry of the list, without hav-
ing to close the dialog box.

OK/Cancel buttons — Click the OK button to confirm changes and close the dia-
log box, or the Cancel button to abandon the changes and close the dialog box.
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Editing Standard MIDI File-based entries

This type of entry will automatically select the Song Play mode, and assign a 
Standard MIDI File (“.MID” or “.KAR” file) to one of the Players (or Sequencers).

• Choose a Standard MIDI File-based entry and double-click it to open the Edit 
MIDI Entry dialog box.

With this type of entry, you can write the full path of the Standard MIDI File used 
as the resource.

(1)

(2) (3) (4)

(6)

(9)

(7)

(5)

(8)

(1) Parameters (2) Standard MIDI File drive unit  
(3) Standard MIDI File path (4) Update icon (5) Resource file browse icon 

(6) TXT file drive unit (7) TXT file path (8) TXT file browse icon 
(9) Previous/Next Entry buttons

Parameters — These are the same parameters found in the Book Edit pages of 
the instrument. Entries created on the Pa or imported get the starting Tempo 
of the Standard MIDI File. Entries created in SongBook Editor, or edited in order 
to change the referred Standard MIDI File, get a default blank Tempo value (---).

Standard MIDI File and text paths — The Standard MIDI File and text paths are 
divided into the drive unit (on the left) and the actual path (on the right). This al-
lows you to change the drive separately from the path, so that you can copy en-
tire directories between drives, without having to re-edit long directory strings.
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An example of path is the following:

c:\foldername1\foldername2\filename.mid

When editing multiple entries, you can only edit the path, but not the file name; 
this is useful if you renamed the folder, or have moved the songs to a different 
folder or directory level. Check the Resource file path checkbox, and enter a 
string similar to the following one (without any final backslash):

c:\newfoldername1\newfoldername2

Storage devices, like hard drives and USB storage devices, are represented by 
IDs, as in the table seen above for the Styles.

Update icon — Click this icon to update the information contained in the Standard 
MIDI File (in case the file contains any). To be used when the linked file has been 
replaced with an updated one.

Browse icons — Click this icon to open a standard file selector, and choose the 
Standard MIDI File or the text file.

Previous/Next Entry buttons — Click the Previous button to edit the previous 
entry of the list, or the Next button to edit the next entry of the list, without hav-
ing to close the dialog box.

OK/Cancel buttons — Click the OK button to confirm changes and close the dia-
log box, or the Cancel button to abandon the changes and close the dialog box.
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Editing MP3-based entries

This type of entry will automatically select the Song Play mode, and assign an 
MP3 file to one of the Players (or Sequencers).

• Choose an MP3 file-based entry, and double-click it to open the Edit MP3 Entry 
dialog box.

With this type of entry, you can write the full path of the MP3 file used as the 
resource.

(1)

(2) (3) (4)(5)

(6) (7) (8)

(9)

(1) Parameters (2) MP3 drive unit (3) MP3 file path  
(4) Update icon (5) Resource file browse icon 

(6) TXT file drive unit (7) TXT file path (8) TXT file browse icon 
(9) Previous/Next Entry buttons

Parameters — These are the same parameters found in the Book Edit pages of 
the instrument. Entries based on MP3 files get a default blank Tempo value (---). 
The Update icon updates ID3 tags (in case the MP3 file contains any of them).

Editing of the various parameters is the same seen above for Standard MIDI File-
based entries.
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Custom Lists
Custom Lists are collections of SongBook entries selected from the complete 
Book list. You can use them to create your own playlists. Up to 256 Custom Lists 
can be contained into each SongBook database.

Creating a new Custom List

• Choose the Edit > New List (Ctrl+L) command to create a 
new Custom List. As an alternative, right-click anywhere in 
the Custom Lists panel and choose the New List command. 
The new list will appear in the Custom Lists panel.

Custom Lists are contained in a “.SBL” file saved in the 
same “SongBook” folder as the Book (“.SBD”) file.

Adding entries to the selected 
Custom List

1 Select the Custom List to which you want to add entries.

2 Grab entries from the Book panel, and drag them onto the 
Selected List panel.

Hint: You can use the Shift+click shortcut to select multiple contiguous entries, or the 
Ctrl+click shortcut to select multiple non-contiguous entries.
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Seeing the content of a Custom List

• Click a Custom List name in the Custom Lists panel to see its content in the 
Selected List panel on its right.

The Custom List’s content is shown in a database-like fashion, with each entry in 
a row, and the various parameters of the entry in adjacent columns.

Contrary to the Book list, this list cannot be ordered in a different way by clicking 
the various column headers. The only possible order is the one shown in the list, 
that is the order in which the entries will be played back.

Editing entries

You can apply to the entries shown in the Selected List panel the same edit-
ing operations already discussed for the entries shown in the Book panel. See 
“Editing the SongBook entries” on page 24 for more information.

Moving entries up/down

You can reorganize the entries in the Custom Lists or the Selected List panel by 
moving each of them to a different position.

• Simply drag&drop the entries to move them up or down the list.

• As an alternative, select the item to be moved, then choose the Edit > Move Up 
(Ctrl+Arrow Up) or Move Down (Ctrl+Arrow Down) command.

• You can right-click the entry and choose the Move Up or Move Down command.



33

English

Deleting a Custom List

You can delete Custom Lists you no longer need.

• Select the Custom List to be deleted in the Custom Lists panel, then press 
Delete.

• As an alternative, right-click the item to be deleted, then choose the Delete 
command.
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Frequent operations
There are some frequent operations that can be carried on, and that SongBook 
Editor makes easy to do on a PC.

Changing reference to a bank of Styles

Styles can be freely moved to different banks. This may be useful, for example, 
when switching to a new instrument and having to reorganize the internal data 
structure of the User, Favorite and Custom Factory banks.

When Styles are moved to a different bank, links from Style-based entries are 
lost. By using SongBook Editor, you can quickly and easily relink all entries to the 
new bank of Styles.

 Back up the current SongBook file

• On the Pa, save the SongBook into a new “.SET” folder to keep a safety copy.

 Load the old SongBook file and Styles

1 Load the old SongBook file by using the Load > [foldername .SET] > Songbook 
operation.

2 Separately load each of the old banks of Styles into the new User/Favorite banks, 
by using the Load > Style > Bank operation.

3 Save a new “.SET’ folder into the internal memory by using the Save > All opera-
tion.

 Edit the SongBook from the PC

1 Connect your Pa to a PC by using a standard USB cable, and enable USB com-
munication (see page 8).

2 From the PC, access the internal memory of the Pa.

3 Run SongBook Editor and choose your new Pa-Series instrument as the Target.

4 Open the “.SET” folder you just created. The old SongBook file and the names of 
the Styles will be loaded.
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5 In the Book panel, click the Resource column header to group all the entries by 
Style bank.

6 Select all SongBook entries that were linked to a particular Style bank (for ex-
ample, all the entries linked to all the Styles from [Factory07 - 01] to [Factory07 
- 32]).

7 Right-click the selected entries and choose the Edit command to open the Edit 
Style Entry dialog box for multiple entry editing.

8 In the Edit Style Entry dialog box, you can edit the Bank parameter, by checking 
the corresponding checkbox. Change the old bank to the bank where you loaded 
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your Styles (for example, change it from Factory07 to User01). Confirm by click-
ing OK.

9 Notice how all selected entries are now referenced to a different bank of Styles 
(for example, from [User01 - 01] to [User01 - 32]).

10 Save the SongBook file and load it back to your Pa (see page 43).



37

English

Changing reference to individual Styles

Multiple-entry editing allows for assigning a different musical resource to sev-
eral SongBook entries at once. This can be useful, for example, to point to a Style 
that you moved to a different position inside your instrument.

 Connect the Pa to a PC

1 On the Pa, save the SongBook to the internal memory.

2 Connect your Pa to a PC by using a standard USB cable, and enable USB com-
munication (see page 8).

3 From the PC, access the internal memory of the Pa, and make a backup copy of 
the “.SET” folder where you saved the SongBook.

 Prepare the Custom Lists

1 Run SongBook Editor, and load the “.SET” folder where you saved the SongBook.

2 Create a new Custom List corresponding to the Style you want to move. Name 
it after the name of the Style. Select the new list to open it in the Selected List 
panel.
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3 In the Book panel, click the Resource column header to group all the entries by 
Style. Find all the entries based on the Style you want to move, and drag them 
onto the Selected List panel. The entries will be added to the new list.

4 Repeat the above operations for all the Style you want to move to a new position.

5 When finished editing, save the SongBook file, and close it.

 Edit the Style banks on the Pa

1 On the Pa, disable USB communication.

2 Move the Styles to their new position.

3 When finished editing, save the Style banks by using the Save > Style operation. 
Note: Be sure to only save the Styles, and avoid overwriting the SongBook file.

4 Enable USB connection again.

 Edit the SongBook from the PC

1 Run SongBook Editor, and load the “.SET” folder where you saved the SongBook 
and the Style banks.
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2 In the Custom Lists panel, select one of the new Custom Lists where you saved 
all the entries associated to one of the Styles you just moved.

3 In the Selected List panel, select all the entries of the selected list.

4 Right-click the selected entries, and choose the Edit command to open the Edit 
Style Entry dialog box for multiple entry editing.

5 In the Edit Style Entry dialog box, check the Bank and Position checkboxes of 
the Style line, choose the bank containing the Style and its new position, then 
click OK to close the dialog box.

6 Notice how all selected entries are now referenced to the correct Style.

7 Repeat the above operations for all the Style you moved to a new position.

8 Save the SongBook file and load it back to your Pa (see page 43).
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Changing the device and path to your Standard 
MIDI Files, MP3 files and Lyrics text files

It is easy to reassign Standard MIDI Files, MP3 files or lyrics text files to the 
SongBook entries. This will prove very useful when you switch to a new instru-
ment, and have to move your whole archive to the new location. Also, it will be 
useful when moving your files to a different device or folder, for example from 
the internal memory to an USB memory stick, or from the root of a disk to the 
“Standard MIDI File”, “MP3” or “Lyrics” folder.

When editing a single entry, you can edit both the drive unit, the file path and 
the file name. When editing multiple entries, you can only edit the drive unit and 
the file path.

1 Select the entry(es) to be edited, right-click it (them) and choose the Edit com-
mand.

2 When the (multiple) entries open, locate the Resource file or Text file line (or 
check the Unit and/or Path checkboxes of the Resources File and/or Text Files 
Path parameters in case of multiple entries).

3 Choose (or write) the new device or path in the relevant boxes.

You can also click the yellow folder icon ( ) to browse and locate the new file 
in the connected devices.

Storage devices, like hard drives and USB storage devices, are represented by 
IDs (see table on page 26).

4 Save the SongBook file and load it back to your Pa (see page 43).
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Merging entries from two SongBook files

You can merge entries from different SongBook files, by opening two (or more) 
application sessions, each one with a different SongBook file.

Note: When copying an entry to a different SongBook file, the entry’s Song Selection 
Number is removed.

Note: When using multiple application instances, choose the same Target on all instances 
(see “Choosing the Target” on page 10).

1 Run SongBook Editor and open the first SongBook file.

2 Run a second session of SongBook Editor and open the second SongBook file.

3 With the windows of both sessions on-screen, drag&drop entries from one win-
dow to the other one. You can also drag&drop entries between the Book and 
Selected List panels. When moving an entry from a source Selected List to a 
target one, the corresponding entry will be automatically created at the target 
Book panel.

4 If duplicated entries are found, you are given a choice between keeping the origi-
nal one, overwriting it, or specifying a different name for the new one.

5 Save the SongBook file and load it back to your Pa (see page 43).
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Exporting a list of entries

You can save the content of the Book list or the selected Custom List as a 
text (“.TXT”) file. This is the same type of file generated, for example, by the 
SongBook > Page Menu > Export As Text File command on the Pa.

Hint: To print a text file, use a non-proportional font (e.g., Courier) and the landscape page 
layout.

 By using the Export command

• Choose the File > Export Book… (Ctrl+E) command to save the Book list as a 
text (“.TXT”) file.

• Select a Custom List in the Custom Lists panel, then choose the File > Export 
List ‘[name of the list]’… (Ctrl+Shift+E) to save the selected Custom List as a 
text (“.TXT”) file.

 By using the Copy command

1 Select some entries in the Book or the Selected List panel.

2 Choose the Edit > Copy (Ctrl+C) command to copy the selected data.

3 Switch to a text editor or a spreadsheet, and paste the copied data in an open 
document.

 By using drag&drop

1 Select some entries in the Book or the Selected List panel.

2 Drag the entries to the open document of a text editor or a spreadsheet, and 
drop the selected data at the target position.

Note: Drag&drop might not work with some software. Please refer to the software’s man-
ual for more information.



43

English

Saving the SongBook files 
and reloading to the Pa
Once finished editing, save the SongBook file and load it back to your Pa.

Saving the edited SongBook file

After editing, save the edited SongBook file.

• Choose the File > Save (Ctrl+S) command to save the file at the original position.

• Choose the Save As… (Ctrl+Shift+S) command to save a new file at the desired 
position. When choosing this command, first create a “.SET” folder, then save 
into it. The SongBook (“.SBD”) and Custom List (“.SBL”) files will be saved inside 
the new folder.

Quitting SongBook Editor

When finished editing and saving your data, you can quit SongBook Editor.

• Choose the File > Quit (Ctrl+Q) command to quit from SongBook Editor.

Disconnecting the Pa from the PC

After having saved all the files, you can disconnect the Pa from the PC.

• On the PC, click the Window’s Toolbar > Safe Hardware Removal icon (  ), and 
select the Pa’s internal memory to disconnect it from the PC.

Loading the edited SongBook files on the Pa

To make the edited SongBook files active, you must reload them.

• On the Pa, use the relevant Media (Disk) > Load operation to load back the edited 
“SONGBOOK” folder from the “.SET” folder. The active SongBook database will 
be updated.
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• If you moved the linked resource files to an external library device, connect it to 
your Pa’s USB Host port. Leave this device connected to the Pa each time you 
want to use the SongBook.
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Appendix

Keyboard shortcuts

The following table shows the key combinations that can be used to choose 
menu commands.

Command Shortcut Right-click

File menu

New 

Open… Ctrl+O

Save Ctrl+S

Save As… Ctrl+Shift+S

Import Files… Ctrl+I

Export Book… Ctrl+E

Export Selected List… Ctrl+Shift+E

Preferences…

Quit Ctrl+Q

Edit menu

Cut Ctrl+X √

Copy Ctrl+C √

Paste Ctrl+V √

Delete Del √

Select All Ctrl+A √

Move Up Ctrl+Up √

Move Down Ctrl+Down √

New Entry > Style Ctrl+N √

New Entry > MIDI Ctrl+Shift+N √

New Entry > MP3 Alt+N √

New List Ctrl+L

Filter… Ctrl+F

Help menu

SongBook Editor User Guide F1

About…
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Version History

Since its introduction, the SongBook Editor has been subject to improvements 
and addition of new parameters. Please find below the changes since version 1.0.

 Version 1 .5 .0

• Now compatible with Pa900, Pa600 (v1.1) and Pa300

• Now compatible with Microsoft Windows 8™

• Added Bank, Style and Voice Preset names in the Book and Selected List panels 
and Edit dialog box

• SongBook files saved in the target format

 Version 1 .4 .1

• Fixed a bug when exporting lists in TXT format

• Fixed a bug that prevented editing Song Numbers

 Version 1 .4 .0

• Now compatible with Pa3X v1.1

• Now compatible with Microsoft Windows 7™

• Added support to Unicode characters

• Changed the procedure to select the target instrument

• Bank and Location numbers can be separately entered when editing a Style-
based entry

• The Key value is correctly imported from a Standard MIDI File associated to a 
new SongBook entry; with Pa3X, this is also true for Master Transpose

• Fixed a bug that caused major and minor keys to appear inverted in the Edit 
dialog box

 Version 1 .3 .0

• Now compatible with Pa2X and Pa500/Pa588

• Improved compatibility with Pa1X v3.01 and Pa800 v1.51
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• Now compatible with Microsoft Windows Vista™

• Changed New Entry-MIDI shortcut

• Fixed a bug that caused major and minor keys to appear inverted in the Main 
screen

 Version 1 .2 .0

• Now compatible with Pa800 and Pa1X (v3.0)

• Style position and Standard MIDI File/MP3/TXT file path editable

• File > Import command added

• Edit > New Entry menu revised

• Edited entries shown in red (or any custom color)

• Selectable file format (Pa1X or Pa800)

• Saved files are no longer compatible with Pa1X prior to v3.0

• New shortcuts

 Version 1 .1 .0

• Now compatible with Pa1X OS (v2.5.x) 

• Song Selection Number reset when copying a Entry from a SongBook file to a 
different one

• Harmony Track parameter added 

• Resource parameter added
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